关注VPS服务器
相关知识分享

WordPress 5.0 禁用 Gutenberg 编辑器 用回 Classic Editor 经典编辑器的方法

自从 WordPress 5.0 版本发布之后,大家吐槽最多的是 Gutenberg 编辑器(古腾堡),都说用不太习惯,也不喜欢这个新版本编辑器的操作方式。如果你想回到经典编辑器,wordpress 默认是不允许的,需要添加插件才能实现。本文中魏艾斯博客详细讲解这几种插件。

老魏也安装试用了一下这款新编辑器(也叫 Block Editor 编辑器,区块编辑器),上手就一脸懵逼,不知道功能区都跑哪里去了,不知道怎么编辑、发布文章,相信很多人和我有同样的遭遇。Gutenberg (古腾堡)编辑器插件的评分为两星,已经很低了,群里面也是一片抱怨的声音。所以说网络上对于这款新版编辑器的差评还是蛮多的。

既然不好用又无法退回 WordPress 4.9版本,那么就想办法解决这个问题吧。

一、Classic Editor插件

在 WordPress 后台管理中的插件>>安装插件搜索 Classic Editor,点击现在安装和启用。

通过 WordPress 后台菜单设置>>撰写,进入设置,配置解释如下:

经典编辑器就是 wordpress 5.0以下版本的老编辑器,也叫经典编辑器。区块编辑器就是新版本 Gutenberg (古腾堡)编辑器。

还能选择是否允许用户切换编辑器。

二、Disable Gutenberg 插件

和上面一样搜索安装并启用 Disable Gutenberg 插件。

用起来也很简单,在 wordpress 管理后台的设置 >> Disable Gutenberg 中,勾选 Disable Gutenberg everywhere 就是所有作者都禁用 Gutenberg 编辑器了,记得保存才能生效。

如果只让一部分特定用户和文章类型禁用,就要不勾选 Disable Gutenberg everywhere 选项。取消后显示更多选项如下图:

这里就是按需要选择了,针对管理员、编辑、作者、投稿者、订阅者、文章、页面都可以单独设置是否禁用 Gutenberg 编辑器。如果当前某个插件与 Gutenberg 编辑器不兼容,而你又希望网站上其他地域可以使用 Gutenberg,这款插件可以使用。

赞(0) 打赏
允许转载,保留出处:魏艾斯笔记 » WordPress 5.0 禁用 Gutenberg 编辑器 用回 Classic Editor 经典编辑器的方法
分享到: 更多 (0)

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏