关注VPS服务器
相关知识分享

CentOS5/6 升级 Python2.4/2.6 到 2.7 版本教程

当魏艾斯博客写教程的时候,有时候需要 Python2.7 版本来实现环境搭建,而很多网友还在使用默认的 CentOS5/6 版本,对应的是 Python2.4/2.6 版本的。为了让这部分网友能够顺利使用,所以就有了今天的CentOS5/6 升级 Python2.4/2.6 到 2.7 版本流程

1、检查当前 python 版本。

老魏给测试系统安装的是 centos5.11 版本,可以说是比较低的了。先来看看 Python 的版本是什么,输入命令:

python -V

cen5pysjdq01

可以看到目前是 python2.43 版本,无法达到部分程序的使用要求,需要进行升级操作。OK,follow me。

2、安装 GCC 编译器

yum -y install gcc

3、下载/解压 Python-2.7 安装包

一般来说安装 python2.7 版本就足够大部分程序使用了。另外 python 官网在国外了,国内 VPS 下载速度真心不快,如果你 VPS 放在国外了那速度肯定是飞快的。或者你可以通过网页下载,然后再用 ftp 上传到 root 目录中去。

wget https://www.python.org/ftp/python/2.7/Python-2.7.tar.bz2

cen5pysjdq02

4、解压缩并进入安装目录

这里没什么好说的,照着输入就是了。

tar -jxvf Python-2.7.tar.bz2
cd Python-2.7

5、安装 python2.7 版本程序

./configure
make all
make install
make clean
make distclean

6、查看 2.7 版本是否生效

/usr/local/bin/python2.7 -V

cen5pysjdq03

当前目录下面已经是 2.7 版本了,不过还需要通过建立软连接,使系统默认的 python 指向 python2.7

7、修改默认指向 python2.7

mv /usr/bin/python /usr/bin/python2.4
ln -s /usr/local/bin/python2.7 /usr/bin/python

cen5pysjdq04

mv 命令后面需要输入 y 确认一下才能继续。

8、再次检测 python 版本

cen5pysjdq05

9、解决 yum 不能运行的问题。

当系统默认 Python 软链接指向 Python2.7 版本后,yum 不兼容 Python 2.7 导致 yum 不能正常工作,所以需要指定 yum 的 Python 版本。这时候使用到了 vi 命令。

vi /usr/bin/yum

输入 a 开始编辑,将文件头部的
#!/usr/bin/python

改成
#!/usr/bin/python2.4

改完后如下图。

cen5pysjdq06

按 ESC 退出编辑状态,输入:wq 保存退出。

上面拿 centos5 系统写的python2.4 升级到 2.7 版本教程,如果你是 centos6 系统,是python2.6.6 升级到 2.7 版本的过程与上面是一样的,只是注意输入 2.6 版本目录的时候不要输错了,然后也同样可以顺利升级到 2.7 或者更高版本。

到这里 CentOS5/6 升级 Python2.4/2.6 到 2.7 版本完成了,整个过程分为两个部分,第一部分是下载程序建立软连接,第二部分是修改 yum 指向,还是比较简单的,不懂的照着做就是了。

赞(0) 打赏
允许转载,保留出处:魏艾斯笔记 » CentOS5/6 升级 Python2.4/2.6 到 2.7 版本教程

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏